missing files and folders when streaming

Please post questions regarding SqueezeCenter, Home Media Streaming Server, UPnP AV services here.

missing files and folders when streaming

Postby slimpig » Tue Mar 08, 2011 1:56 am

I'm playing back video and music through my WDTVLive, when I first got the ReadNAS duo, everything worked ok. But as soon as I put on the firmware update half of my files and folders are missing when I select to play files via the ReadyNAS as a Media Server. If I select to play the files via the ReadNAS as a network share the files and folders are all there. The only problem being selecting the network share method is that it sometimes takes several attempts to connect to the ReadyNAS as a network share, connecting as a Media Server is instant. No matter how oftern I rescan the folders (under the streaming media service bit in the websetup) they just don't appear on the media server playback. Its really annoying that it worked when I first got it, and I don't want to downgrade the firmware as its supposed to loose data.

Has anyone else had this problem and did they manage to fix it?
slimpig
ReadyNAS Newbie
 
Posts: 1
Joined: Tue Mar 08, 2011 1:42 am
ReadyNAS: Duo

Re: missing files and folders when streaming

Postby Iversen » Thu Mar 10, 2011 4:36 am

put me on this list... just updated my NV+ yesterday and a lot of mkv, iso etc files are no longer visible to my WDHD Live...

maybe install Twonky media server?

anyone?
Iversen
ReadyNAS Newbie
 
Posts: 2
Joined: Thu Mar 10, 2011 3:42 am
ReadyNAS: NV+

Re: missing files and folders when streaming

Postby Iversen » Mon Mar 14, 2011 4:40 am

update :-)

after FW update all permissions on the shares has been reset.
so after updating the share permissions all work perfectly again :-)

its important that the WD can write/read to the NAS because the WD has to place the WB.bin file on the server
to be able to read the correct shared files :-)
Iversen
ReadyNAS Newbie
 
Posts: 2
Joined: Thu Mar 10, 2011 3:42 am
ReadyNAS: NV+

Re: missing files and folders when streaming

Postby vic20ian » Sun Apr 17, 2011 9:20 am

Can I do a firmware update of 4.2.16 over 4.2.16 to force this?

How did you diagnose it was permissions?

I have a similar problem with DLNA not updating / showing all folders but all are accessible by browsing on pc or by readynas remote
vic20ian
ReadyNAS Newbie
 
Posts: 28
Joined: Thu Apr 14, 2011 11:01 am
ReadyNAS: Ultra

Re: missing files and folders when streaming

Postby vic20ian » Sat Apr 30, 2011 7:55 am

Fixed by removing DV containing files for now till 4.1.17 is released
vic20ian
ReadyNAS Newbie
 
Posts: 28
Joined: Thu Apr 14, 2011 11:01 am
ReadyNAS: Ultra

Re: missing files and folders when streaming

Postby aghcanuck » Mon May 02, 2011 7:45 am

Can you please post the steps you took to solve?

Brgds,
a.g.h.
aghcanuck
ReadyNAS Newbie
 
Posts: 1
Joined: Mon May 02, 2011 7:39 am
ReadyNAS: NV+

Re: missing files and folders when streaming

Postby dang0404 » Tue Jul 12, 2011 5:32 pm

Hi All, i have the same issue, dont believe any update has happened. I run a WDTV live and a ReadyNAS NV+, but the WD only see's like 2 or 3 folders and not 5 or 6 like it should.

I have been working on this for a while and cant seem to come up with a solution. Had a look through these forums and couldn't see anyone else have a definite solution either.

Is there someone to contact about this issue as it was working fine for months then just started doing this.

Any advice would be appreciated.

Cheers
Dan
dang0404
ReadyNAS Newbie
 
Posts: 2
Joined: Tue Jul 12, 2011 5:24 pm
ReadyNAS: NV+

Re: missing files and folders when streaming

Postby vuilverwerking » Wed Jul 13, 2011 6:30 am

Maybe updating ReadyDLNA is a option? > viewtopic.php?f=76&t=27946
Frontview > Services > Streaming services > Under ReadyDLNA hit the 'Rescan media files' button.

@vic20ian:
Do you browse the ReadyNAS with DLNA protocol from your PC?
NAS:Netgear ReadyNAS NVX Pioneer Edition RNDX400E
Network:Linksys WRT54GL, TP-Link WR1043N
Clients: Windows 8.1 Update 1,Hyper-V Server 2008, Freecom MusicPal, Xtreamer MK1(Sidewinder kit), Sony BRAVIA KDL-40NX700
User avatar
vuilverwerking
ReadyNAS User
 
Posts: 87
Joined: Sat Oct 02, 2010 1:07 pm
Location: Netherlands
ReadyNAS: NVX

Re: missing files and folders when streaming

Postby dang0404 » Wed Jul 13, 2011 3:51 pm

Hi, i tried that and still missing folders when viewing on WD live box.

I can see them when viewing via PC, or on the NAS itself. Currently out of ideas.

Cheers
Dan
dang0404
ReadyNAS Newbie
 
Posts: 2
Joined: Tue Jul 12, 2011 5:24 pm
ReadyNAS: NV+

Re: missing files and folders when streaming

Postby ringo » Fri Jul 15, 2011 1:00 am

Hi,
I have the same problem.
With upgrading my Ultra6 to 4.2.17 (from 4.2.15) mediascan does not complete and only 2 folders of many more are found.
DLNA upgrade to 1.0.20 does not help. With 4.2.15 there were no problem.
Furthermore I have a NV+ with RAIDiator 4.1.7 and an old dlna version. Works with no problem. But its urgent that the Utra works.
Has anyone any idea and/or suggestions to fix this problem.
Up to now, I does not found anything in this forum which could help to fix my problem.

Sometimes I think this problem seems insignificant for Netgear.
Altough there exist customers which use and bought their product ONLY for media streaming,
no updates/comments/workarounds in sight???

thanks a lot for any suggestions which could help.
thanks for any reply that gives me the feeling that I am not alone.
Ultra6 RAIDiator 4.2.17 dlna 1.0.20 and NV+ RAIDiator 4.1.7 dlna 1.0.18.2
ringo
ReadyNAS Newbie
 
Posts: 2
Joined: Fri Jul 15, 2011 12:28 am
ReadyNAS: Ultra

Re: missing files and folders when streaming

Postby vuilverwerking » Fri Jul 15, 2011 10:16 am

NAS:Netgear ReadyNAS NVX Pioneer Edition RNDX400E
Network:Linksys WRT54GL, TP-Link WR1043N
Clients: Windows 8.1 Update 1,Hyper-V Server 2008, Freecom MusicPal, Xtreamer MK1(Sidewinder kit), Sony BRAVIA KDL-40NX700
User avatar
vuilverwerking
ReadyNAS User
 
Posts: 87
Joined: Sat Oct 02, 2010 1:07 pm
Location: Netherlands
ReadyNAS: NVX

Re: missing files and folders when streaming

Postby ringo » Sun Jul 17, 2011 3:02 pm

I think not that there are corrupt files (but I will check next weekend),
because I copied the movie folder from my Ultra to my NV+ and my NV+ (with RAIDiator 4.1.7 dlna 1.0.18.2) has no problems to scan.
The NV+ streams perfect (as the Ultra before the upgrade to 4.2.17).
Ultra6 RAIDiator 4.2.17 dlna 1.0.20 and NV+ RAIDiator 4.1.7 dlna 1.0.18.2
ringo
ReadyNAS Newbie
 
Posts: 2
Joined: Fri Jul 15, 2011 12:28 am
ReadyNAS: Ultra

Re: missing files and folders when streaming

Postby captjohnno » Wed Aug 10, 2011 5:03 am

dang0404 wrote:Hi All, i have the same issue, dont believe any update has happened. I run a WDTV live and a ReadyNAS NV+, but the WD only see's like 2 or 3 folders and not 5 or 6 like it should.

I have been working on this for a while and cant seem to come up with a solution. Had a look through these forums and couldn't see anyone else have a definite solution either.

Is there someone to contact about this issue as it was working fine for months then just started doing this.

Any advice would be appreciated.

Cheers
Dan


Same issue for me on WDTV Live and PS3... only shows top 4 folders on both devices. Netgear support haven't been able to resolve.
captjohnno
ReadyNAS Newbie
 
Posts: 12
Joined: Fri Apr 23, 2010 6:16 pm
ReadyNAS: Duo

Re: missing files and folders when streaming

Postby klockareson » Thu Aug 25, 2011 8:55 am

dang0404 wrote:Hi All, i have the same issue, dont believe any update has happened. I run a WDTV live and a ReadyNAS NV+, but the WD only see's like 2 or 3 folders and not 5 or 6 like it should.

I have been working on this for a while and cant seem to come up with a solution. Had a look through these forums and couldn't see anyone else have a definite solution either.

Is there someone to contact about this issue as it was working fine for months then just started doing this.

Any advice would be appreciated.

Cheers
Dan


Same issue here. I run PS3, TVIX 7000 and ReadyNAS Duo...Only a brink of the folders are shown and also...When I try to rescan for new mediafiles, the button is greyed out.

Anyone got a clue here?

Jeppe
klockareson
ReadyNAS Newbie
 
Posts: 6
Joined: Wed Mar 24, 2010 5:01 am
ReadyNAS: Duo

Re: missing files and folders when streaming

Postby dillyhammer » Sun Sep 04, 2011 5:52 am

I seem to be experiencing something similar with an NV+. I have whole swaths of files and folders missing. For example, I have a folder that contains 85 files, but only the top 54 show - an 8GB mkv file is missing as are all the files after it. Some folders missing altogether. This is with uPnP/DLNA. All files and folders visible and accessible via CIFS. I'm chocking it up to a buggy uPnP/DLNA implementaiton until I hear or see otherwise.

Edit - I've done a little more experimenting. I attempted to stop the ReadyDLNA service, and it came up with an "error stopping ReadyDLNA service". The "rescan media files" button was greyed out. So I started the service. In WM, the movies showed up, up to but not including to what appeared to be an offending 8GB mkv file. So, I removed that file and again tried to stop the ReadyDLNA service, and again it came up with "error stopping ReadyDLNA service". I started it. The media scan has now gone beyond the apparently offending file and is picking up stuff it hadn't seen before. It appears as though the scanner is choking on the offending file and either giving up or restarting then choking on the same file again. Humbly, this appears to be a pretty nasty bug in the media scanner.

Edit - Swapped out the ReadyDNLA with the debug version. Now I can watch this happen. The scanner is totally wonky. When it comes across a file it doesn't like, it chokes and dies, along with any watches it previously set. According to the bug database for minidnla, upon which this add-on is based, this appears to be a known issue. This needs to be bloody well fixed, tell you what. Using CIFS to access files via shares is the only workaround. Pretty sad if you ask me. The Netgear folks need to get on this, pronto. Normally I would say "with all due respect", but I'm out $350, $700 counting the 4X2TB disks. I'll be calling support in the morning to register my displeasure. I suggest anyone else experiencing this problem do the same.

For the time being, I've disabled ReadyDNLA. It's totally busted.

Mike
Last edited by dillyhammer on Sun Sep 04, 2011 10:45 am, edited 4 times in total.
dillyhammer
ReadyNAS Newbie
 
Posts: 14
Joined: Sat Sep 03, 2011 10:59 am

Next

Return to Streaming Services



Who is online

Users browsing this forum: No registered users and 1 guest