Can't set share folder group ownership in Domain mode

Please post questions and issues pertaining to share access and file permission here.

Can't set share folder group ownership in Domain mode

Postby beq » Fri May 12, 2006 3:38 pm

I have a ReadyNAS NV (p9) in Domain security mode, successfully joined to the AD domain. It correctly displays all the user and group accounts, and has synchronized its clock directly from the primary domain controller (Win2K Server).

I created 13 shares, which by default were set to share folder owner/group: 'admin'/'admin' (shown in Advanced Options for each share).

I can change the share folder owner and group, and the NV validates that they're valid user and group accounts (or throws up an error box otherwise). The problem is that the share folder group setting doesn't stick, even when done correctly. When I go back to the Advanced Options page for that share, the group setting still shows 'admin'.

To be more accurate: if I change the share folder owner by itself, the change sticks. But if I change both share folder owner and group at the same time, neither sticks. And if I change the share folder group by itself, it doesn't stick either.

I've tried various group accounts that we have, including 'Domain Users', 'ACCT TEAM', etc.

Can anyone help? I can send the logs or provide remote access if necessary...
beq
ReadyNAS Expert
 
Posts: 259
Joined: Fri Apr 14, 2006 3:50 am
Location: USA

Postby ewok » Fri May 12, 2006 5:40 pm

This appears to be a bug in the way the Advanced Options page handles owners and groups with spaces in them. Please try using a group name without spaces to verify the problem. This will be fixed in the next release.
User avatar
ewok
Jedi Council
 
Posts: 9455
Joined: Tue Mar 08, 2005 3:58 pm
Location: Fremont, CA
ReadyNAS: Pro

Postby beq » Sat May 13, 2006 2:02 am

You're right, renaming the groups without spaces fixed it, thanks!

In fact I don't even have to change the actual name of each domain group, just its pre-Win2000 name (as the latter field is what the ReadyNAS sees and validates). I was a bit hesitant to rename the NT built-in groups such as 'Domain Users' and 'Domain Admins' though.

Funny thing is, I can rename these groups back to have spaces in their names afterwards, and the ReadyNAS will automatically change the share folder group field to reflect the change. So this is a workaround :)
beq
ReadyNAS Expert
 
Posts: 259
Joined: Fri Apr 14, 2006 3:50 am
Location: USA

Postby JaseUK » Tue May 16, 2006 1:24 am

Boy am I glad I found this!

Just for clarification - should I rename every security group to have an underscore where there is a space in the Pre Windows 2000 group name?

When is the firmware that fixes this issue likely to be released?

Thanks in advance
Jason
JaseUK
ReadyNAS Newbie
 
Posts: 28
Joined: Fri May 05, 2006 5:26 am


Return to Share Access and File Permission



Who is online

Users browsing this forum: No registered users and 2 guests