BitTorent Download manager shows no progress

Please post questions about add-ons for legacy ReadyNAS devices here.

BitTorent Download manager shows no progress

Postby cor » Tue Feb 26, 2008 3:27 am

I installed the BitTorrent addon, mapped the right directory, configured my firewall and added a torrentfile. After adding the file there is no progress. Has anyone a idea? I use RAIDiator 4.01c1-p1.
cor
ReadyNAS Newbie
 
Posts: 9
Joined: Sat Jan 12, 2008 4:32 am

Postby super-poussin » Tue Feb 26, 2008 8:19 am

did you see peers in the interface ?
If you like my add-ons - Si vous aimez mes add-ons :
EN/US:Image --- -------- FR: Image or Paypal @mail: readynas@orange.fr
Where I'm teaching
4B Perros
User avatar
super-poussin
ReadyNAS Add-ons Expert
 
Posts: 5144
Joined: Fri Jul 13, 2007 1:16 pm
Location: PG
ReadyNAS: RN516

Postby chirpa » Tue Feb 26, 2008 10:26 am

Did you check that the torrent is Started? If you click on the torrent, details are shown at the bottom, like seeders and such. How about a screenshot?
User avatar
chirpa
Jedi Council Alumni
 
Posts: 16133
Joined: Mon Sep 24, 2007 11:52 am
Location: San Jose, CA
ReadyNAS: Repertoire

Postby NatureDude » Tue Feb 26, 2008 2:14 pm

I'm not seeing much in mine either. Mostly 0 with the occasional spike up to a few hundred bytes/s. The same torrents under windows (uTorrent) are speeding along.

Are there some ports I have to open, etc? I'm missing something...
NatureDude
Advanced ReadyNAS User
 
Posts: 114
Joined: Wed May 30, 2007 12:20 pm

Postby chirpa » Wed Feb 27, 2008 12:41 am

opening ports will help, but it should still work without any forwarded. can try changing the default port under the Settings tab, your ISP may be filtering that. utorrent by default uses a random port, not the standard 6881 for BT. and does the torrent you loaded have any seeders?
User avatar
chirpa
Jedi Council Alumni
 
Posts: 16133
Joined: Mon Sep 24, 2007 11:52 am
Location: San Jose, CA
ReadyNAS: Repertoire

Postby cor » Wed Feb 27, 2008 5:20 am

Here the screen dump of the torrent client.


Torrent Details: orderofthephoenixtrailer_720.mkv
0%
Size:45.5 MB
Remaining:45.5 MB
Downloaded:0 bytes
Uploaded:0 bytes
Seeds:0 (0)
Peers:0 (1)
Ratio:0
Availability:0
Download Speed:0
Upload Speed:0
Files:
orderofthephoenixtrailer_720.mkv
cor
ReadyNAS Newbie
 
Posts: 9
Joined: Sat Jan 12, 2008 4:32 am

Postby chirpa » Wed Feb 27, 2008 2:10 pm

No seeders would explain no progress. Try an active torrent.

Try this debian cd image torrent, it goes pretty quick for me:

Image
User avatar
chirpa
Jedi Council Alumni
 
Posts: 16133
Joined: Mon Sep 24, 2007 11:52 am
Location: San Jose, CA
ReadyNAS: Repertoire

Postby beisser » Thu Feb 28, 2008 1:09 am

i was able to leech torrents with the nas with more than 3.5 megabytes per second (34mbit line for the win). of course this only works if the torrent has enough seeds and if the seeds are actually seeding fast enough. as chirpa said, the torrent you are trying to get has 0 seeds and only 1 leecher, which means its as dead as it can get.
User avatar
beisser
Jedi Council
 
Posts: 2337
Joined: Mon Dec 10, 2007 3:12 am
Location: Near Munich, Germany
ReadyNAS: Pro

Postby NatureDude » Mon Mar 03, 2008 2:26 pm

Still nothing. Ran overnight and got less than .1% completions. Same thing on my PC completed most of the files overnight. I did change to another port and forwarded it. Yes, same torrents as the PC and they did have seeders and reasonable ratios.

derek wrote:opening ports will help, but it should still work without any forwarded. can try changing the default port under the Settings tab, your ISP may be filtering that. utorrent by default uses a random port, not the standard 6881 for BT. and does the torrent you loaded have any seeders?
NatureDude
Advanced ReadyNAS User
 
Posts: 114
Joined: Wed May 30, 2007 12:20 pm

Postby jaffacake » Thu Mar 06, 2008 1:26 am

If the same torrents are working in uTorrent, then clearly there are seeds.

If there aren't any shown in the ReadyNAS torrent client, it sounds like it may be having a problem retrieving a peer list from the tracker. Are they public or private torrents?

Edit: I just tried with a private torrent site that used passkeys...all works fine. I had to upload the torrent from a file though as cookie auth wasn't possible.
jaffacake
ReadyNAS User
 
Posts: 74
Joined: Mon Apr 30, 2007 5:27 am

Re: BitTorent Download manager shows no progress

Postby Skaven252 » Fri May 16, 2008 11:58 am

Hello all. I'm having similar problems with my ReadyNAS NV+ (RAIDiator 4.01, BitTorrent add-on). I'm connected to the net through a hardware LinkSys BEFSX41 firewall / router / DHCP, which I think I have configured right (port range forwarding: TCP and UDP for the default port 6881 for my ReadyNAS's IP address).

I've tried three different torrents which all showed a large number of peers and seeders, but the download just won't get started. In the ReadyNAS torrent download manager they all show 0 seeds, 0 peers and 0 availability. And the very same torrents work on my PC with UTorrent.

BTW, oddly enough, the ReadyNAS doesn't show in my firewall's DHCP client table, but I can still access it and the network shares / network drives work. Also, the ReadyNAS had a problem downloading a remote update by itself, I had to download it to a file and apply it locally. As if the ReadyNAS was unable to access the internet. Are these problems related?
ReadyNAS NV+ RND4000 - 1Gb RAM - IT3107 processor - 4 x 1.5 TB Samsung EcoGreen F2 - RAIDiator 4.1.6
Skaven252
ReadyNAS Newbie
 
Posts: 38
Joined: Sat May 03, 2008 11:36 pm
Location: Finland
ReadyNAS: NV+

Re: BitTorent Download manager shows no progress

Postby chirpa » Fri May 16, 2008 12:37 pm

Did you set a static IP on your ReadyNAS, or via DHCP?

If it can't download torrents, or get remote updates, sounds like DNS and Gateway settings might not be correct.
User avatar
chirpa
Jedi Council Alumni
 
Posts: 16133
Joined: Mon Sep 24, 2007 11:52 am
Location: San Jose, CA
ReadyNAS: Repertoire

Re: BitTorent Download manager shows no progress

Postby Skaven252 » Fri May 16, 2008 12:47 pm

Thanks for your reply.

I gave it a static IP address (the LinkSys is acting as the DHCP server). And after adding the torrents I noticed that the IP addresses of my ISP's DNS servers were missing, so I added them.

I've set the default gateway to the LinkSys firewall default, 192.168.1.1 - is that correct?

What other settings should I check?
ReadyNAS NV+ RND4000 - 1Gb RAM - IT3107 processor - 4 x 1.5 TB Samsung EcoGreen F2 - RAIDiator 4.1.6
Skaven252
ReadyNAS Newbie
 
Posts: 38
Joined: Sat May 03, 2008 11:36 pm
Location: Finland
ReadyNAS: NV+

Re: BitTorent Download manager shows no progress

Postby chirpa » Fri May 16, 2008 12:53 pm

Once DNS and Gateway are populated, it should work, maybe do a reboot for good measure.
User avatar
chirpa
Jedi Council Alumni
 
Posts: 16133
Joined: Mon Sep 24, 2007 11:52 am
Location: San Jose, CA
ReadyNAS: Repertoire

Re: BitTorent Download manager shows no progress

Postby Skaven252 » Fri May 16, 2008 1:05 pm

Oh yes, after rebooting the torrets started flowing. Thanks! :)

BTW, is the add-on supposed to re-install every time you boot? It displayed "installing add-on" on the LCD screen again.
ReadyNAS NV+ RND4000 - 1Gb RAM - IT3107 processor - 4 x 1.5 TB Samsung EcoGreen F2 - RAIDiator 4.1.6
Skaven252
ReadyNAS Newbie
 
Posts: 38
Joined: Sat May 03, 2008 11:36 pm
Location: Finland
ReadyNAS: NV+

Next

Return to General Discussion on ReadyNAS Add-ons for Legacy ReadyNAS



Who is online

Users browsing this forum: No registered users and 5 guests