Torrents Downloading but NOT Uploading...

Please post questions about add-ons for legacy ReadyNAS devices here.

Torrents Downloading but NOT Uploading...

Postby Lennart_Myra » Wed Feb 03, 2010 7:08 pm

Hello,

I have a big problem with getting my NAS to work properly when it comes to torrents. When I use BitTorrent or Transmission I have no problems with downloading the torrents, but when it comes to uploading, nothing happens.

My download is usually maxed at 2,5mb/s, but uploading always stays at 0kb/s (sometimes it may go to like 5kb/s for a few seconds then back to 0 again)....What is the problem?

I am currently using a Cisco EPC2425 router which is connected to my Readynas Duo...

If additional info is required to solve it, please tell me....


Thanks!

/Lennart_Myra
Lennart_Myra
ReadyNAS Newbie
 
Posts: 5
Joined: Wed Feb 03, 2010 6:42 pm
ReadyNAS: Duo

Re: Torrents Downloading but NOT Uploading...

Postby Seraph » Thu Feb 04, 2010 8:11 am

Have you forwarded the necessary port to your NAS on your router?
Seraph
ReadyNAS Newbie
 
Posts: 41
Joined: Fri Jan 22, 2010 9:02 am
ReadyNAS: NV+

Re: Torrents Downloading but NOT Uploading...

Postby Lennart_Myra » Thu Feb 04, 2010 8:39 am

I am not sure I got that part 100% right...

It looks like this when I configure the router:

Setup
Advanced Settings - Port Forwarding
This page allows you to configure port forwarding for local IP addresses.

Local IP Adr - Start Port - End Port - Protocol - Enable

X - X - X - X - X

What exactly should I put in these cells?

(In my torrent client it says: network: incoming tcp port: 51413)

Thanks again!
Lennart_Myra
ReadyNAS Newbie
 
Posts: 5
Joined: Wed Feb 03, 2010 6:42 pm
ReadyNAS: Duo

Re: Torrents Downloading but NOT Uploading...

Postby Seraph » Thu Feb 04, 2010 8:42 am

Lennart_Myra wrote:I am not sure I got that part 100% right...
Local IP Adr - Start Port - End Port - Protocol - Enable

X - X - X - X - X


Local IP Adr: Your NAS' IP address.
Start port: 6881 (if you're using the built-in bittorrent client) or 51413 (if you're using the Transmission add-on)
End port: Same as above.
Protocol: TCP/UDP (or if you have to choose one of the two, choose TCP)
Enable: checked

Hope this helps.
Seraph
ReadyNAS Newbie
 
Posts: 41
Joined: Fri Jan 22, 2010 9:02 am
ReadyNAS: NV+

Re: Torrents Downloading but NOT Uploading...

Postby Lennart_Myra » Thu Feb 04, 2010 8:51 am

Thank you for the quick answer! I have now tried it, but still nothing happens with my upload :(

Any other ideas?
Lennart_Myra
ReadyNAS Newbie
 
Posts: 5
Joined: Wed Feb 03, 2010 6:42 pm
ReadyNAS: Duo

Re: Torrents Downloading but NOT Uploading...

Postby Seraph » Thu Feb 04, 2010 9:23 am

What IP did you set for your nas. It should be the internal IP (probably starting with 192.168 or 10.0).

What port did you set, and what bittorrent client are you using?
Seraph
ReadyNAS Newbie
 
Posts: 41
Joined: Fri Jan 22, 2010 9:02 am
ReadyNAS: NV+

Re: Torrents Downloading but NOT Uploading...

Postby Seraph » Thu Feb 04, 2010 9:24 am

Oh... by the way, it should be noted that the bittorrent client on the NAS is not set to seed any of the files it downloads. It will only upload while you are downloading.
Seraph
ReadyNAS Newbie
 
Posts: 41
Joined: Fri Jan 22, 2010 9:02 am
ReadyNAS: NV+

Re: Torrents Downloading but NOT Uploading...

Postby Lennart_Myra » Thu Feb 04, 2010 11:45 am

My NAS received the ip 192.168.0.11 and I am using Transmission 1.83...it says something about tcp port 51413 in the preferences...

I tried forwarding that port and ip numbers, but still nothing is uploading...only downloading...
Lennart_Myra
ReadyNAS Newbie
 
Posts: 5
Joined: Wed Feb 03, 2010 6:42 pm
ReadyNAS: Duo

Re: Torrents Downloading but NOT Uploading...

Postby Seraph » Thu Feb 04, 2010 11:48 am

Is it a problem if nothing is uploading? eg. Are you not getting fast downloads because of it?

If you've done the forwarding correctly, there shouldn't be anything else getting in the way. I would suggest trying out the 1.90 beta that you can find here (if you are using a Duo or NV+):

http://www.readynas.com/contributed/sup ... 1Light.bin
Seraph
ReadyNAS Newbie
 
Posts: 41
Joined: Fri Jan 22, 2010 9:02 am
ReadyNAS: NV+

Re: Torrents Downloading but NOT Uploading...

Postby super-poussin » Thu Feb 04, 2010 12:47 pm

there's no upload if there's no leecher asking for the file

1.90 will give you a tab to see tracker status and if there's leechers
If you like my add-ons - Si vous aimez mes add-ons :
EN/US:Image --- -------- FR: Image or Paypal @mail: readynas@orange.fr
Where I'm teaching
4B Perros
User avatar
super-poussin
ReadyNAS Add-ons Expert
 
Posts: 5166
Joined: Fri Jul 13, 2007 1:16 pm
Location: PG
ReadyNAS: RN516

Re: Torrents Downloading but NOT Uploading...

Postby Lennart_Myra » Thu Feb 04, 2010 3:06 pm

Yeah, I really need to be able to upload as well...I will try the 1.90 and see if it helps...thanks again!

There is plenty of leechers so I know that is not the problem...I have tried many different ones with the same result...but when I download the same torrent on my PC, upload is working perfectly...
Lennart_Myra
ReadyNAS Newbie
 
Posts: 5
Joined: Wed Feb 03, 2010 6:42 pm
ReadyNAS: Duo

Re: Torrents Downloading but NOT Uploading...

Postby Tatsu » Sat Feb 06, 2010 1:22 pm

I'm having the same problem with Transmission 1.7x - 1.83.

Port is opened on router (7000 for NAS and 7001 for Mac) and set in Transmission adequately.

When I seed from NAS (NVX) - i get slow upload speed and its very rear.
When I for test stop NAS and start to seed the same torrent on Mac i starts seeding with max speed just after few seconds with up to 40 connections (that what I observed).

I need to seed to get better ratios.

Any help welcome :)
Thanks in advance
Tatsu
User avatar
Tatsu
ReadyNAS Newbie
 
Posts: 5
Joined: Wed Feb 03, 2010 11:24 am
Location: Free City Danzig. POLAND
ReadyNAS: Repertoire

Re: Torrents Downloading but NOT Uploading...

Postby ReVolt » Sun Oct 10, 2010 10:29 am

I have the same problem with the ReadyNas NVX. Ports are correctly forwarded. Downloading torrents works fine, only seeding is a problem. I have max 3 peers and a completely unstable upload. I'm running the latest version of RAIDiator (4.2.13) and Transmission (2.10).

Anyone found a solution yet?
ReVolt
ReadyNAS Newbie
 
Posts: 3
Joined: Sun Oct 10, 2010 10:23 am
ReadyNAS: NVX

Re: Torrents Downloading but NOT Uploading...

Postby ketan324 » Wed Jan 12, 2011 8:44 pm

I have the same problem. I confirmed port forwarding is setup correctly on my router. My Windows 7 laptop has no problem getting to 500k-1Mb/s upload speeds, HOWEVER BitTorrent on the ReadyNAS DUO box is super slow. In fact the upload doesn't appear to be sustained over a period of time. The upload will start/stop randomly, and when it is running I'm lucky if I get more than 30Kb/s upload speed. Does anybody have suggestions or fixes for this issue? Are their other clients I can test out on the NAS box? Btw, download is not an issue at all, I average around 1Mb/s most of the time. Thanks.
ketan324
ReadyNAS Newbie
 
Posts: 5
Joined: Wed Jan 12, 2011 8:37 pm
ReadyNAS: Duo

Re: Torrents Downloading but NOT Uploading...

Postby Tatsu » Thu Jan 13, 2011 12:22 am

OK so I checked the other configuration iMac with bittorent client but changed storage destination to ReadyNAS share and got the same results as with bittorent client on ReadyNAS.
User avatar
Tatsu
ReadyNAS Newbie
 
Posts: 5
Joined: Wed Feb 03, 2010 11:24 am
Location: Free City Danzig. POLAND
ReadyNAS: Repertoire

Next

Return to General Discussion on ReadyNAS Add-ons for Legacy ReadyNAS



Who is online

Users browsing this forum: No registered users and 3 guests