openvpn segmentation fault

Please post questions about add-ons for legacy ReadyNAS devices here.

openvpn segmentation fault

Postby davidrough » Mon Oct 15, 2012 7:17 am

I installed the openvpn package via apt in order to try and get my readnas NV+ 4.1.10 going with new vpn account.

nas:/etc/openvpn# cat client.conf
client
dev tun
proto udp
remote swiss.privateinternetaccess.com 1194
resolv-retry infinite
nobind
persist-key
persist-tun
ca ca.crt
tls-client
remote-cert-tls server
auth-user-pass
comp-lzo
verb 1
reneg-sec 0

when starting:

nas:/etc/openvpn# openvpn client.conf
Options error: Unrecognized option or missing parameter(s) in client.conf:11: remote-cert-tls (2.0)
Use --help for more information.

If I # out "remote-cert-tls server" and then run I get:

nas:/etc/openvpn# openvpn client.conf
Mon Oct 15 16:13:01 2012 OpenVPN 2.0 sparc-unknown-linux [SSL] [LZO] [EPOLL] built on Jan 17 2007
Enter Auth Username:USERXXXX
Enter Auth Password: PASSWORDXXXX
Mon Oct 15 16:13:44 2012 IMPORTANT: OpenVPN's default port number is now 1194, based on an official port number assignment by IANA. OpenVPN 2.0-beta16 and earlier used 5000 as the default port.
Mon Oct 15 16:13:44 2012 WARNING: No server certificate verification method has been enabled. See http://openvpn.net/howto.html#mitm for more info.
Mon Oct 15 16:13:44 2012 LZO compression initialized
Mon Oct 15 16:13:44 2012 RESOLVE: NOTE: swiss.privateinternetaccess.com resolves to 3 addresses, choosing one by random
Mon Oct 15 16:13:44 2012 UDPv4 link local: [undef]
Mon Oct 15 16:13:44 2012 UDPv4 link remote: 31.7.56.170:1194
Segmentation fault

The version is as follows:

nas:/etc/openvpn# openvpn --version
OpenVPN 2.0 sparc-unknown-linux [SSL] [LZO] [EPOLL] built on Jan 17 2007
Developed by James Yonan
Copyright (C) 2002-2005 OpenVPN Solutions LLC <info@openvpn.net>

Any ideas on how to resolve this one ?
davidrough
ReadyNAS Newbie
 
Posts: 15
Joined: Sun Dec 19, 2010 10:07 am
ReadyNAS: NV+

Re: openvpn segmentation fault

Postby mvrana » Thu Nov 01, 2012 7:09 am

Have you tried getting in touch with privateinternetaccess.com? They might be able to help.
mvrana
ReadyNAS Newbie
 
Posts: 1
Joined: Thu Nov 01, 2012 7:04 am

Re: openvpn segmentation fault

Postby RudeYute » Thu Dec 26, 2013 3:13 pm

Did you ever fix this? I am having the same problem and PIA weren't able to help get it working - instead they tried to encourage me to buy a new router which supports a custom firmware which supports OpenVPN.
RudeYute
ReadyNAS Newbie
 
Posts: 3
Joined: Fri Mar 12, 2010 10:51 am


Return to General Discussion on ReadyNAS Add-ons for Legacy ReadyNAS



Who is online

Users browsing this forum: No registered users and 6 guests