ssh

Please post questions that doesn't fall into the above categories here.

ssh

Postby thockin » Sat Oct 26, 2013 3:14 pm

ReadyNAS ultra4

I am tried of flaky behavior, and I want to look at real logs. I toggled SSH and installed EnableRootSSH. I can establish a connection by SSH, but it does not take the admin password. I am SURE I am not mis-typing it. :)

Any clues where to look next?
thockin
ReadyNAS Newbie
 
Posts: 5
Joined: Sat Oct 26, 2013 3:08 pm
ReadyNAS: Ultra

Re: ssh

Postby mdgm » Sat Oct 26, 2013 3:22 pm

You have to login as the 'root' user with the 'admin' password. The 'root' user's passwords initially set to be the same as the 'admin' password. Remember the add-on is EnableRootSSH
User avatar
mdgm
NETGEAR ReadyNAS Technical Expert
 
Posts: 34993
Joined: Tue Feb 17, 2009 9:34 pm
Location: Down Under
ReadyNAS: RN516

Re: ssh

Postby thockin » Sat Oct 26, 2013 3:57 pm

I am attempting to log in as root.

$ ssh root@10.5.69.250
root@10.5.69.250's password:
Permission denied, please try again.
thockin
ReadyNAS Newbie
 
Posts: 5
Joined: Sat Oct 26, 2013 3:08 pm
ReadyNAS: Ultra

Re: ssh

Postby mdgm » Sat Oct 26, 2013 5:26 pm

Try installing EnableRootSSH again
User avatar
mdgm
NETGEAR ReadyNAS Technical Expert
 
Posts: 34993
Joined: Tue Feb 17, 2009 9:34 pm
Location: Down Under
ReadyNAS: RN516

Re: ssh

Postby thockin » Mon Oct 28, 2013 9:15 pm

Did that. No love.
thockin
ReadyNAS Newbie
 
Posts: 5
Joined: Sat Oct 26, 2013 3:08 pm
ReadyNAS: Ultra

Re: ssh

Postby pdelges » Wed Dec 04, 2013 3:31 am

Did you find a solution?

I have the same problem with a NVX (RAIDiator 4.2.25).
I'm sure I could ssh as root before. Now I get a permission denied error. I tried to install EnableRootSSH several times, and to reboot too. Strangely, I can't "'shutdown and reboot" nor "shutdown and turn off device" from Frontview anymore (I need to press the power button 3 times). It worked the first time I installed EnableRootSSH today, but not anymore.

ssh as admin with the admin password does work, but the connection is closed:

Code: Select all
[PAt:~] pdelges% ssh admin@192.168.0.7
admin@192.168.0.7's password:
Last login: Wed Dec  4 11:10:39 2013 from 192.168.0.15 on pts/0
Linux BU-2TbRaid 2.6.37.6.RNx86_32.1.4 #1 Wed Oct 23 11:00:31 PDT 2013 i686 GNU/Linux
Last login: Wed Dec  4 11:20:05 2013 from 192.168.0.15
Connection to 192.168.0.7 closed.
[PAt:~] pdelges% ssh root@192.168.0.7
root@192.168.0.7's password:
Permission denied, please try again.
1x NVX, 1x Ultra2+, 1x RN312
User avatar
pdelges
ReadyNAS Newbie
 
Posts: 32
Joined: Fri Jul 10, 2009 8:24 am
Location: Belgium
ReadyNAS: NVX

Re: ssh

Postby mdgm » Thu Dec 05, 2013 4:04 am

As I suspected your root line in your /etc/shadow file was messed up.

Should be working now.
User avatar
mdgm
NETGEAR ReadyNAS Technical Expert
 
Posts: 34993
Joined: Tue Feb 17, 2009 9:34 pm
Location: Down Under
ReadyNAS: RN516


Return to General Questions (English)



Who is online

Users browsing this forum: Google Feedfetcher, Yahoo [Bot] and 7 guests