Streaming to Xbox 360 - Strange behaviour

(Replaces the existing UPnP-AV server support) Enables playback of videos, music and pictures from DLNA/UPnP AV network media players. Also adds TiVo HMO support.

Streaming to Xbox 360 - Strange behaviour

Postby mynamestom » Mon Jan 17, 2011 1:04 pm

First let me say thank you to everyone who posts and contributes to these forums - I have found a lot of useful hints and tips which made using my ReadyNas Duo a lot easier!

My setup
ReadyNas Duo running 4.1.7, Connected via. 100Mb wired
1x 1.5TB Samsung HD154UI Disk
Netgear DG834G Wireless Router (100Mb ports)
iMac Connected via 100Mb wired
Xbox 360 Connected via Wireless

The problem
My Xbox 360 can see my ReadyNAS fine under the Video Library pane, but when selected it just spins the loading icon and shows an error after 30 seconds or so, saying Connection Failed.
However, if I run Connect360 on my iMac the Xbox will happily see and connect to both my iMac, and the NAS no problem.

Essentially if I want to stream from my NAS to my Xbox, my iMac has to be on and Connect360 running and sharing otherwise it will simply not connect.

Has any one else experienced similar issues? Are there any known fixes for this problem?

I work in IT so technical answers/solutions are fine. I have SSH setup and enabled and I'm very comfortable with linux shells and scripting. Anything to fix the problem would be amazing!

Thank you!
mynamestom
ReadyNAS Newbie
 
Posts: 1
Joined: Mon Jan 17, 2011 12:54 pm
ReadyNAS: Duo

Re: Streaming to Xbox 360 - Strange behaviour

Postby doof205 » Mon Mar 14, 2011 2:17 pm

For what it's worth I get the same thing. Seems we've been sold something that isn't fit for it's purpose.

I'm shocked at how difficult this ReadyNAS is to get simply streaming to an Xbox. God help people that aren't technical.

Close to throwing my ReadyNAS in the bit, seems to be junk.
doof205
ReadyNAS Newbie
 
Posts: 4
Joined: Mon Mar 14, 2011 1:45 pm
ReadyNAS: Duo

Re: Streaming to Xbox 360 - Strange behaviour

Postby jman » Mon Mar 14, 2011 3:09 pm

hey guys, i can assure you you haven't bought a dud and the readynas streams perfectly to the Xbox so don't worry!

Firstly, I'd try connecting it via a patch cable. I know some routers perform odd filtering over the wireless > lan bridge (don't think the DG834 does however - that thing is the most reliable router I've ever owned!). But doesn't hurt to eliminate wireless being the problem.
Then, make sure you're using DHCP - otherwise check your DNS, default gateway and subnet settings are right on the 360.

Failing that - make sure you've got UPnP disabled in frontview. So far as I understand, readyDLNA will respond to probes from devices that look for UPnP sources (this is how the xbox finds the NAS, SSDP packets I believe) without this and I'm not sure how they work together. I have only readyDLNA enabled and it works just fine.

I'm a bit confused as to why the streaming from the NAS would work only when your iMac is on - there aren't any IP address conflicts are there? Maybe I misunderstood that bit.

Let me know how you get on dude.
User avatar
jman
ReadyNAS User
 
Posts: 67
Joined: Mon Feb 16, 2009 5:01 am
Location: UK
ReadyNAS: Duo


Return to ReadyDLNA



Who is online

Users browsing this forum: No registered users and 2 guests